ETH transactions are currently facing a delay

Incident Report for MoonPay

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 22:31 UTC

Identified

We've identified an issue with one of our external partners and are working with them to resolve the issue as soon as possible.
Posted Oct 01, 2025 - 22:20 UTC

Investigating

We are currently experiencing a delay in processing some ETH transactions. We're working on identifying and resolving the issue as soon as possible.
Posted Oct 01, 2025 - 22:14 UTC
This incident affected: Digital Currencies (Global) (Ethereum).