We fixed the issue and Tron balances are now visible for all users. Thank you for your patience and sorry for the inconvenience.
Posted Oct 14, 2025 - 10:43 UTC
Update
Some of our users can't see their Tron wallet's balance. This is caused by an issue with one of our providers that affects a subset of our users.
We're still waiting for our provider to fix the issue. Yesterday was a holiday in their location so today we're hoping for a resolution. In the meantime, you can use Tronscan to view your Tron balance correctly.
Posted Oct 14, 2025 - 08:18 UTC
Identified
Some of our users can't see their Tron wallet's balance. This is caused by an issue with one of our providers that affects a subset of our users.
We're collaborating with our provider to fix the issue as soon as possible, and we'll provide an update soon. In the meantime, you can use any Tron explorer (like Tronscan) to view your Tron balance correctly.
Posted Oct 13, 2025 - 12:45 UTC
This incident affected: Features (Wallet Balances).