Infinite loading of settings screen

Incident Report for MoonPay

Resolved

The issue preventing the settings screen from loading has been resolved. Customers should now be able to access their settings normally.
Posted May 12, 2025 - 19:15 UTC

Identified

We think the impact from the issue is over.
Posted May 12, 2025 - 15:14 UTC
This incident affected: Products (MoonPay App).